Votre navigateur semble ne pas lire le javascript!

Les deux raisons possible :
  - Vous avez désactivé le javascript!
  - Votre navigateur est trop vieux!

Si vous ne résout pas se problème, vous ne pourrez pas utiliser tout les services du site, et d'ailleurs vous ne pourrez pas utiliser un grand nombre de site car il est rare de nos jours qu'un site n'utilise pas le javascript!

Ne craignez rien, c'est sans danger!
Vous etes ici : Accueil/forum/1_modules-de-propulsite /39_formulaire-champ-fichier

Formulaire champ fichier

8 Reponse(s)

Ce sujet est résolu Ce sujet est résolu

Posté par yaclog le 07/03/2012 à 14 H 20 Min
Bonjour,

Tout d'abord, merci pour ce site qui permet l'utilisation de formulaires.

J'ai mis un formulaire avec un champ fichier voici les anomalies que j'ai constaté :

1- avec le champ fichier et uniquement le type de fichier jpg ça ne fonctionne pas, message disant que jpg n'est pas pris en compte.(2ème formulaire dans la liste)

2- avec un champ fichier et deux type de fichier jpg et jpeg ça fonctionne, cependant à l'arrivée les fichiers jpg sont renommés d'office en jpg. (1er formulaire dans la liste)actuellement en service ici :Lien

3- la limite de 5 mo (soit 5120 K0 ou 5242880 octets) n'est pas atteinte alors que l'affichage prévoit 5mo)

Est-il possible de remédier à ces anomalies.

Merci d'avance,

Jean-Louis
Réponse de yaclog posté le 07/03/2012 à 14 H 45 Min
Re-bonjour,

Je rectifie une erreur de frappe dans le précédent post :alinéa 2 : lire : les fichiers jpg sont renommés d'office en jpeg.

Jean-Louis
Réponse de Admin posté le 07/03/2012 à 18 H 59 Min
Bonsoir,
tout d'abord, merci pour ce rapport de bug.

Je n'ai pas tout compris, car à un moment vous parlez de deuxième formulaire dans la liste alors que sur votre page, il n'y en à que un.

Du coup j'ai créer un formulaire avec uniquement le champs jpg, effectivement, il ne fonctionnai pas car ne script php renommé tout les jpg en jpeg alors que sur la page du formulaire, javascript ne le fesait pas, du coup ni les jpg ni les jpeg ne fonctionnaient.

J'ai réparé ce problème, du coup l'erreur 1 et l'erreur 2 devraient être résolue.

Pour ce qui est de la limite, je ne comprend pas ce que vous voulez me dire, 5mo, c'est bien 5120ko, mais quel est le rapport?

J'ai mis cette limite au visuel, mais en réalité, elle est un peut plus élevé, enfin il me semble, car si une personne envoi un fichier de 5,5 mo par exemple, et qu'elle na pas l'adsl, elle devra recommencé après une longue attente....

Vaut mieux laisser une petite marge non?

Après, cela ne devrait pas vous poser problème non?
Réponse de yaclog posté le 09/03/2012 à 13 H 53 Min
Bonjour,

Merci pour votre réponse et pour votre action.

J'ai parlé d'un deuxième formulaire car au départ, les envois ne passaient pas avec l'option jpg seule, j'ai donc créé un second formulaire pour le remplacer (avec jpg et jpeg).les fichiers jpg arrivent bien avec l'extension jpg certainement grâce à votre action.

Actuellement c'est le formulaire qui est en 1er sur la liste en fonctionnement.ça fonctionne maintenant.

En ce qui concerne le poids des fichiers j'avais fait un test avec 1 fichier à 4,34mo ça ne passait pas, Je vais essayer de trouver un fichier au plus proche des 5mo(ou légèrement supérieur) pour faire un nouveau test.En ce qui concerne la marge je suis entièrement d'accord.

En tout état de cause, merci pour ces formulaires, c'est une belle initiative, qui permet au néophyte que je suis, de proposer d'uploader des fichiers à ces visiteurs, ça me dépanne parfaitement (en plus je ne dispose pas de PHP) pendant la défaillance de mon prestataire habituel.

A bientôt,

Jean-Louis
Réponse de Admin posté le 09/03/2012 à 19 H 39 Min
Ok, je jette un oeil pour la taille, je me suis peut être tromper tout simplement dans les calcules.

Au cas ou vous voulez un hébergement performant, fiable et à très bon prix, je vous conseil celui que j'utilise depuis quelques années, le lien est en bas du site à droite.
Réponse de Admin posté le 09/03/2012 à 19 H 44 Min
Aussi tôt dit, aussi tôt fait, je m'étais bien tromper dans les calcules, j'avais fixé la limite à 5125000 au lieu de 5242880.
Du coup, j'ai rectifié, je l'ai placé à 6000000 octets.

Merci pour votre aide, on me signale rarement les bugs comme ceux-ci, pourtant, je suis conscient qu'il y en à pleins....
Réponse de yaclog posté le 09/03/2012 à 23 H 01 Min
Je ne suis pas encore allé tester mais une grand merci pour votre réaction rapide.
A bientôt

JL
Réponse de yaclog posté le 09/03/2012 à 23 H 14 Min
Voilà c'est fait test à 5,71 mo ça passe.Merci

JL
Réponse de Admin posté le 10/03/2012 à 11 H 29 Min
Merci à vous






2 personnes surveillent ce sujet.


Copyright 2010 PROPULSITE Executé en 0.0884 sec.
En ligne : 5 | Aujourd'hui : 268 | Total : 2203725
Partenaire officiel : Menuiserie Schiltigheim : Agencement Vogler